2007年10月12日

HDMobiMail for WM Ver.0.913

あいこん.jpg

2007.10.12 ver.0.913

詳細については以下をご覧下さい。
MI-GI-WAなソフトサポートページ

報告のあった修正のみです。
修正点
・自動受信でHDMobiMailが起動するときに2回受信動作をしていたのを修正
上記yamashuさん他より報告

・デバッグログ出力時にログイン情報がログファイルに出力されていたのを修正
上記skkyさんより報告



posted by ひで@き at 02:35| 東京 🌁| Comment(31) | TrackBack(0) | HDMobiMail | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
>sabaさん
BG自動受信後、見えている画面にフォーカスが当たらないやつですが・・・

GSFinder等を前面に置いて自動受信させ、
初代はこれでGSFinderとかにフォーカスが戻りました。
[es]で同じ事しようとしたんですが
status15をレジストリで直にいじっても
例の「勝手に切断」だかみたいのが邪魔して
自動受信してくれなくなってしまい・・・orz
esではこの辺の検証ができないみたいです。
(すげぇ困った・・・どうすべこれ?)

でですね、
Eメール(Willcom?のタイトルって消えるようになりましたでしょうか?
消えていれば、方法あるかもなので明日以降お試しUPしてみます。
(すいません、今日は限界です(_ _).zZ)
Posted by ひで@き at 2007年10月12日 02:41
はじめまして。HDMobiMailとても便利に使わせていただいてます。

以前のバージョンでsyykさんがご報告されていた
「Gmailで大容量メールを受信するとアプリが落ちる」件ですが、
私の環境でも似たような現象が起きていました。
ただ、Gmail(SSL)ではなくしかも大容量というほどのメールを含んでたわけでもないので
一応ご報告させていただきます。

デバイスはアドエス(WS011SH)、メールアカウントはプロバイダのPOPメール。
サーバに34件メールがたまっている状態で、
そのうちHTMLメールが10件くらい、60KBほどの添付ファイル付きが1件。
このアカウントのメールを受信(全受信、個別受信)すると、
受信処理が完了せずにHDMobiMailが落ちます。
(WMのエラー報告を有効にしていると、エラー報告画面が起きます)
再度HDMobiMailを起動しても受信箱には何も表示されませんし、
フォルダの中を直接見てもメールファイルはありません。

ただ、実はこの現象が起きていたときはActiveSync経由で受信してまして、
ふと思い立ってダイヤルアップで試したところ受信成功いたしました。

双方の詳細ログを見比べてみましたが、
失敗した方は、最後のメールの「メール情報解析[TOP]」で止まってしまってるみたいです。
ただ、このログを出力した時はたまたま最後のメールまで読めたみたいですが、
同じ条件でも落ちるタイミングがもっと早い(最初の5件くらい?)場合もあったのでなんとも言えません。

ちなみに、別のアカウントも設定してまして、
そちらは添付ファイルもHTMLメールも含みませんが、
ActiveSync経由で30件ほどのメールを一気に受信することができていました。


長々と書いてしまいましたが、何かの参考になれば幸いです。
Posted by cxmtop at 2007年10月12日 12:32
>skkyさん、cxmtopさん
軽く見てみましたが、どうも受信時にメモりの解放忘れしているのが有るみたいです。
それが原因かはわかりませんが
(つーかこれだけでも×・・・orz)
今日、明日には再現させて修正します。
Posted by ひで@き at 2007年10月12日 13:23
うーん。残念ながら消えませんね。
まあ、どうも気にしているのは私だけのようでもありますし、あまりお気になさらないでくださいね。
Posted by saba at 2007年10月12日 19:45
度々お世話になってます。
一括送信中に受信入ると固まる件ですが、一括送信の途中で止まってました(2件目送信か振り分けの辺り)。その間に1件目から返信が来てただけのようです。あと、自動受信に失敗した場合にずっと受信待ちで固まってるようなのですが・・・
Posted by とら at 2007年10月12日 23:08
todayから「センターにEメールがあります」が消えないのは仕様ですか?
ad[es]なのでSTMail.exeを置き換えてますが、おとなしくttmail経由で使えということでしょうか?
Posted by psy at 2007年10月12日 23:12
>とらさん
うーーーん。その場合はOKボタンで送受信画面消してください。
消えない場合は・・・うーーん。なぜだろう・・・
どう失敗しているのかによるかもです。
タイムアウトもしないとなると・・・どこだ?

後、一括送信というよりは送信中の受信はとにかくダメでしょうね。。
回避法自体はなんとなく思いついているんですが、
すいません、もう少々待ってもらえませんか?

>psyさん
STMail.exeはダメです。tmail.exeのみの置き換えです。
STMailは呼び方とかも違い、昔試しましたが
1回はうまくいくのですが、2回目以降受信してくれなかったです。
またアドエスはtmail.exeの差し替えも効果が無いと
以前報告受けてますのでttmailをご使用になった方が良いと思います。

>sabaさん
とりあえず、了解しました。
なんでしょね?
Posted by ひで@き at 2007年10月12日 23:29
ごめんなさい、もうひとつ。
どうも添付ファイルが読める読めないが出て来てるみたいです。PC,初代03(当然?),Hotmail,携帯各社はいけるみたいですけど、PHSサンヨーのWX310SAは弾かれました。む〜んなぜに・・・(笑)
Posted by とら at 2007年10月12日 23:31
>とらさん
WX310SA?
弾かれたってのはWX310SAで読めなかったってことですか?
Posted by ひで@き at 2007年10月12日 23:58
はい、そうです。
<#ほげほげ>しか出ないらしいです。
Posted by とら at 2007年10月13日 00:27
>とらさん
・・・ほぉ・・・
<#ほげほげ>
↑本文ですか?

なんだろ?
特におかしな情報は送ってないと思うんですが・・・
って、困ったな。確認しようもないし・・・
Posted by ひで@き at 2007年10月13日 00:35
※下の方のリンクでお願いします。


・受信時のメモリリーク
・送信中の自動受信
・メイン画面の削除(CTRL+D)、全削除(CTRL+T)
が効いていなかったのを修正です。

Gmail40通で内容がまずいのか固まりはしませんでしたが、
メモリが減り続け、受信完了後も解放されない
のを確認してそこを修正しました。

多分大丈夫だとは思いますが、一応ご確認願えますか?
>ALL
Posted by ひで@き at 2007年10月13日 00:59
本文はまた別で、それに添付ファイル部分が<#〜>です。
ですよね〜。他できちんと表示されてるし・・・

過去のバージョンでボーダフォンの何かから送られてきた添付ファイルが全く同じ症状でこちら側で見れないって言うことはありましたが・・・はて・・・
Posted by とら at 2007年10月13日 01:01
http://www.pelu.jp/download/hdmobimail/hdmobimail0913b_exe.zip

度々すいません。
skkyさんから報告の有ったメールの文字化け対応です。
えーーとなんだっけ?
Googleカレンダーからの送られてくるメールが化けるってやつです。
UTF-8+Quoted Printableの組み合わせがNGでした。

0913aの方は消しておきます。
例によって1日様子見で正式UPします。
Posted by ひで@き at 2007年10月13日 02:45
テストさせていただきました。ありがとうございます。

その前にまず、一度受信したメールを再度受信するには「conf\uidl.xml」の削除で問題ありませんでしょうか?
一応、以下はその状態で試した結果です。

受信した内容は以前とほぼ同じで、違うのはメールの数が38通に増えたくらいです。
問題だったActiveSync経由での受信ですが、
やはり同じように受信完了せず落ちてしまいました。
(エラー報告画面も同様。)
しかも今回は6回中5回が、1通も受信できずに落ちてしまってます。
残りの1回は30通目で落ちたようです。

ダイヤルアップは以前と同じく受信できました。
また、無線LANでも試そうと思いましたが、
ウチの無線ルータが調子悪くテストできていません。すみません。

ちなみに、受信処理が完了せずに終了した時の受信ファイルですが、
「maildir\inbox\」フォルダ内に存在してました。
メールボックスの振り分けが実行されず、しかもHDMobiMailの受信箱からも見えなかったので保存されていないのかと思いましたが。
保存できているようならこれが見えるようになるといいのでは?と思いました。
Posted by cxmtop at 2007年10月13日 02:56
一点言い忘れ^^;
送信中の自動受信対応は
「送信完了後に続けて受信動作を行う」
です。

>cxmtopさん
再受信はそのファイル削除でOKです。

で、まだ直りませんか・・・orz
こっちで起きたらもっとわかりやすいんですが・・・
ただメール数でもなさそうですね。
0913bのリンクの中身を更新しました。
DEBUGを埋め込み、解析TOP以降の怪しいところで
同じ様なデバッグ文を出力するようにしています。
すいませんがこれでもう一度試してみていただけませんか?
出来ればそのTOP解析途中で止まってしまった
メールファイルを改変して送っていただけると助かります。


後、索引ファイル再構成(メールファイルから索引を作り直す)は・・・・
いや・・・今の作業それなんですが、
バグ多い(且つ再現しにくい)のと
MFC版のリリースの疲れが一気に来てて、頭が回りません・・・
すいませんが、もうしばらくお待ち下さい・・・
Posted by ひで@き at 2007年10月13日 03:15
・・・ぐ・・・
さっきエラー報告出たのに
次から出てこない・・・orz
なんなんだ、一体
Posted by ひで@き at 2007年10月13日 03:31
あれ、すれ違いでしたね。夜遅くまでありがとうございます。

hdmobimail0913b_exeでも早速ActiveSyncで試しましたところ、
1回だけActiveSyncで受信成功できました。
その後も同じ条件で失敗したりするので良い報告とは言えませんが……。
解析途中で止まったメール(すみません、特定できてないかもしれません)を添付してmigiwa-hideaki@pelu.jpまで送らせていただきました

また、Gmailの方はわかりませんが、
以前は中身を開けなかった、はてなグループ(Hatena::G)の更新レポートメールが読めるようになっていました。
タイトルが若干化けてますが。それは他のいくつかのメールでも同様なので。


>すいませんが、もうしばらくお待ち下さい・・・

こちらこそ、急がせてしまっているようで申し訳ありません。
どうか、ひで@きさんのペースで進めてくださいませ。
Posted by cxmtop at 2007年10月13日 04:00
>cxmtopさん
すいません、煮詰まってしまって・・・
メール確認しました。
・・・開けますね・・・orz
解析は同じ処理なので。

ちょっとこちらで再現が難しそうなので
継続調査対象とさせていただきます。

お手数おかけして申し訳ありません。
Posted by ひで@き at 2007年10月13日 11:16
追記です。
デバッグログ出力するようにすると、
かなりの量が出力されますので
定期的に削除等してください。
Posted by ひで@き at 2007年10月13日 11:18
受信メールの振り分け(TOによる振り分け)ができないメールが有ります。
メニューの【振り分け設定】⇒【TO】をやってみると、そこに出てくるアドレスが文字化けをしています。どうもアドレス解析に問題が有るようですね。
ちなみに【TO】は willpop@gmail.com と入っているだけのシンプルなメールで、同じTOでも振り分け出来るメールと出来ないメールが有ります。
必要であれば、問題の有るメールを転送します。
Posted by サム at 2007年10月13日 11:49
>サムさん
うご・・・まだ有るのか・・・
そうですね。送っていただけると助かります。
メールアドレスは書式、半角全角等が分かれば
大丈夫だと思います。
宜しくお願いします
Posted by ひで@き at 2007年10月13日 12:17
こちらでもダイヤルアップでは問題なく受信できますので、
保留にしていただいてかまいません。
お付き合いいただきありがとうございました。

無線LANでの受信もテストできたらまたご報告させていただきます。
Posted by cxmtop at 2007年10月13日 12:46
お疲れ様です。
度々すみません。一括送信の件です。
普通に一括送信すると、最後の振り分けの段階で1つ振り分けられずに残りつつ固まってます。とりあえずここで砂時計・・・
[DEBG] 071013 21:24:21-[===========Quit Server===========]
[DEBG] 071013 21:24:21-[SndDataCRLFN]QUIT


[DEBG] 071013 21:24:21-[SndData]QUIT
[DEBG] 071013 21:24:21-+OK Pop server at pdx.ne.jp signing off.


BG一括送信すると、処理は帰ってきますが、やっぱり送信控えに残ります。送信自体は問題ないようです。

のんびりいきましょ〜
Posted by とら at 2007年10月13日 21:51
>cxmtopさん
すいませんです。
ダイアルアップはOKってのが
よく分からないですね(-_-;)

>とらさん
0914で修正しました。
かなり初期の頃からみたいですが気がつかなかったです。

ご心配おかけしてすいません。
ちょっと難しいのが立て続いたんで
煮詰まってました・・・orz
(って解決してないけど)
Posted by ひで@き at 2007年10月14日 00:00
To振り分け失敗のサンプル、メールしときました。
Posted by サム at 2007年10月14日 08:53
(最新版にバージョンアップさせていただきましたが、 こちらにコメントさせていただきます。) 先ほど無線LANによる受信も成功いたしました。 実用上まったく問題なさそうですね。
Posted by cxmtop at 2007年10月14日 12:19
>サムさん
はい。1通目は受け取りました。ありがとうございます。
ただ、ちょっと分からないところがあったので
返信メールしましたが、届かなかったですかね?

>cxmtopさん
了解です^^

なっかなか再現しづらいですね、これ(-_-;)
一応メールを溜め込んでいるので
判明したら対処します。
Posted by ひで@き at 2007年10月15日 01:30
はじめまして、このソフトを0821からバージョンアップさせてもらいました。

zero3[es]で使用していますが、マナーモードを設定しているときに、自動受信を始めると3秒ほどバイブレーションをすることに関して、なにか対策はありますでしょうか?
Posted by iwatobi at 2007年10月15日 23:40
申し訳ありません、ひとつ古いほうに書いてしまいました。
Posted by iwatobi at 2007年10月15日 23:48
>iwatobiさん
一応こちらに。
0915で修正しました。
詳細は0914のコメントで。

初代はマナーでも発生しなかった(設定変えたかもだけど)ので
気がつかなかったです。
Posted by ひで@き at 2007年10月16日 11:55
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック

広告


この広告は60日以上更新がないブログに表示がされております。

以下のいずれかの方法で非表示にすることが可能です。

・記事の投稿、編集をおこなう
・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。


×

この広告は1年以上新しい記事の投稿がないブログに表示されております。