2007年10月13日

HDMobiMail for WM Ver.0.914



あいこん.jpg

2007.10.13 ver.0.914

詳細については以下をご覧下さい。
MI-GI-WAなソフトサポートページ

例によって
報告を受けたバグの修正のみです。
(全部直っているわけではないですが・・)
posted by ひで@き at 23:56| 東京 ☁| Comment(19) | TrackBack(0) | 日記 | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
どうも振り分けを部分一致にしていただいてありがとうです。
まだ振り分けができないのがあるので調べたら、FROMが「日本語<address>」だとうまくいかないようです。
ツールの振り分け設定→FROMにするとメアド欄が「@」だけの条件入力画面が出てきます。
Posted by 5 at 2007年10月14日 01:06
>5さん
確認ですが、日本語<メアド>で
日本語に[@]いませんかね?
メアド意外に@有ると解析がうまくいかないです。
なかなか良い方法が思いつかなくて・・・
Readmeに書き損なってたか・・・
Posted by ひで@き at 2007年10月14日 01:14
勝手ながら要望をあげさせてもらっても良いでしょうか?

アドエス+MFC版(最新版)で使用させていただいています。

・メール受信時にエラーがでるとエラー画面が
表示されて止まりますが、これをスルーして
(もしくは3秒ぐらい表示して閉じる)
処理を先に進めるような事は出来ないでしょうか?
ウィルコムのアカ+他3個のアカウントで
使用しているのですがttmailで自動受信時に
エラーが出ると、そこで止まってしまい
受信したこともわからずそれ以降の自動受信も
怪しい状態です。
他3個のアカのうち1個が接続エラーしまくり
(PCでも)なので、エラーが無視されると
非常に助かります。
Posted by PentaTwist at 2007年10月14日 01:30
連日のブラッシュアップ、お疲れ様です。大変だとは思いますが、着々と素晴らしいソフトに仕上がりつつありますのでがんばっていただきたいと思います。HDMobiMailを使ってしまうともう他のメーラーには戻れなくなります。微力ながら完成度を高めるお手伝いができればと思っております。

さて、最新の0.914を使わせていただいていますが、私のところで発生している不具合をご報告します。

単純なのですが、メールを自動受信してそのままの状態でまた次の自動受信…と繰り返していくと、何通目かでHDMobiMailが落ちてしまいます。また、それ以降自動受信もできなくなってしまったりもします。

確実な再現性はなく、現象は不安定です。他のアプリを使用した後などは起こりやすいような気もします。リセット直後にHDMobiMailだけしか使っていないときは比較的起きにくいように思えます。

現象の不安定さから見て、メモリ管理関係の不具合のように思えます。メモリリークが見つかっているようですが、まだ残っているのかもしれませんね。私の環境は初代ZERO3ですので搭載メモリが少ないので起き易いのかもしれません。

夜中に何通ものメールが届きますが、何通か着信したところでそれ以上受信できなくなっています。そのときも手動受信ではちゃんと受信はできます。

環境が違うと再現しにくいかもしれませんが、とにかく私の環境ではほぼ再現します。

改良のご参考になれば幸いです。
Posted by くゎぢ at 2007年10月14日 11:47
pdxメールの送信で不具合があります。
不具合というか、Ver.0.912以降pdxメールが送れなくなりました。
(他アカウントメールは送れる)
(0.911に戻すと送れる)

・エラーメッセージは、
*******************************
SMTP ERR
[bsmtp.pdx.ne.jp][SMTP-
550]:メールボックスが利用でき
ないため、要求された処理は実
行不能
*******************************
というウィンドウが開きます。

・エラーメッセージが表示されるまでの、メッセージの推移は、

Connect POP for SMTP Server(bsmpt.pdx.ne.jp)

Login SMTP Server(bsmpt.pdx.ne.jp)

Login (ここでエラー)

・ログを確認すると、

*********************************
[DEBG] 071014 12:31:20-[===========送信ファイルMap作成===========]
[DEBG] 071014 12:31:20-[===========メール送信===========]
[DEBG] 071014 12:31:20-[SndDataCRLFN]MAIL FROM:<@>


[DEBG] 071014 12:31:20-[SndData]MAIL FROM:<@>
[DEBG] 071014 12:31:20-[GetSrvRet]550 Requested action not taken, maybe invalid format


[DEBG] 071014 12:31:23-[SndDataCRLFN]QUIT


[DEBG] 071014 12:31:23-[SndData]QUIT
************************

本来なら自分のメールアドレスが入るべきところに
<@>
という文字が入ってしまっているのが原因でしょうか。そもそも、正常時のログでは[SndDataN]となっている部分が全て[SndDataCRLFN]となっている所から、改行の制御なのかな。。。。

ということで確認をお願い致します。

余談ですが、私も早くVer.0.914に上げて(昔出来ていた)振り分けを部分一致にしないと振り分け条件が多く、時間がかかってしょうがありません。

Posted by 相川 at 2007年10月14日 16:19
>相川さん
上にも書いていますが、メアドの形式で
メアド以外の部分に@入っていませんか?
メアドの抽出処理と思われます。
あるいはメアドのみとか。
できればメアドの書式教えて下さい。

今出先なのですぐには直せません。
すいません。
Posted by ひで@き at 2007年10月14日 16:53
ちなみに@の件ですが
もうちょっとお待ち下さい。
なんとなく見えてはきたんで。
・・・・正規表現使えれば・・・・orz
といいつつメアドに関してはちょっと正規表現を信じきれなくなってるし。
つーか、メアドってかなり色々許されていて
まっとうな正規表現ではものすごいことになった気が・・・
Posted by ひで@き at 2007年10月14日 17:05
原因がわかりました。

自分の名前に全角・半角空白があるとこの現象になりますね。

「差出人 名前<aaaaa@wm.pdx.ne.jp>」

この形式だとNGになりますが、

「差出人名前<aaaaa@wm.pdx.ne.jp>」

これで無事送信できます。

自分のメールアドレスを拾うとき、空白が邪魔して抽出できていないんでしょうね。

とりあえず空白が無くても困らないので、無事0.914を使う事にしました!!

Posted by 相川 at 2007年10月14日 17:33
お疲れ様です。
バッチリですね〜♪
Posted by とら at 2007年10月14日 21:17
> 相川さん

自分も同じ症状でしばらく0.9.11使ってました。
回避策ありがとうございます。
Posted by シワシワ at 2007年10月14日 22:06
たしかに相川さんの指摘の通りのようです。
振り分けできないアドレスは半角スペースがはいっていました。
Posted by 5 at 2007年10月15日 00:16
>5さん、相川さん、シワシワさん
http://www.pelu.jp/download/hdmobimail/hdmobimail0914a_exe.zip
直ったと思い・・・
・・・あれ?
全角空白なら再現できたんですが、
半角空白だと再現できないんですけど・・・

「あああ あああ<メアド>」●「@」になる
「あああ あああ<メアド>」×「メアドになる」

うーーん。取りあえず原因としては
[@]を探し出す処理で全角の2バイト目が64[@]のものっぽいですね。
なので半角空白というよりはその全角のどこかに
[@]と同じコード持っているのがいると思われます。
というわけで
前から言っている「メアド以外の@はまずい」
ってのを修正しました。
念のためメアド以外の場所で色々試してみましたが
(@、半角空白、全角空白、仮名、英等)
とりあえず問題なさそうです。

>PentaTwistさん
うーーーーーーん。お気持ちは分かりますが・・
PCですらエラーが起きやすい状態では
ただでさえ回線が不安定な無線通信の場合
立て続けに起きてサーバとの接続が切られたりするので
あまりそういうのは・・・
極論で行けば送受信時のメッセージを全てログ出力のみに限定という形ならなんとか。
ただその場合はなんらかの方法で通知しないと
「受信したはずなのに受信されてない」
なんて言われても困る事に^^;

ま、確かにOKおさにゃいかんのはうざいですね。
上の方法で良ければ考えます
(Beckyのステータスバーにエラー出すだけみたいな)

どちらにせよ現在は要望はよほど簡単で無い限り
取りかかっていないので
一覧に上げるだけになります。
ご了承下さい。

>くゎぢさん
ブラッシュアップ・・・なるほどこう言えば
なんか前向きな感じですな。
(いや、結局バグつぶしなんだけど)
まず一つ自動受信のキックにHDMobiMail.exeかHDChkMailか分かりませんが、
HDChkMailの方は一部開放漏れが有りました。
一応その点修正してます。




というわけで
メモリリークの調査に時間がかかりすぎて
遅くなってすいません。

HDMobiMailの受信処理ですが結局分からずじまいです。
ってかリークの調べ方がわからん。
マクロ使えないのかな・・・

といいつつ地味に調査しましたが、
ファイルの書き込み系のキャッシュ?というのか
ファイルアクセスが有ると一部実行メモリに「何かが」残っているみたいで
それ以外は結構綺麗に消えていた「よう」です。
無論「完璧に」とは言えないので調査は継続します。
HDMobiMail使わなくても実行メモリはチビチビへっているのでなんともねぇ・・状態です。

ちなみに大量メール受信は今日はリーク調査もかねて30通程度で試しましたが
どうも起きてくれません・・・orz
もうちょっと実データそろってからまたやります。
Posted by ひで@き at 2007年10月15日 01:08
書き忘れ
>相川さん
お手数お掛けして申し訳ありません。
助かりました。
Posted by ひで@き at 2007年10月15日 01:21
空気読めてなくてすみません。

HDChkMail.exeなのですが、起動すると『ピロリン♪』って音が出るのと、電源LEDが黄緑色に点滅するのは仕様なのでしょうか。

WS011SHでttmail+tmail(As Time Goes Byさんとこ)と併用なので、黄緑点滅は一定時間後終わってるみたいなのでいいんですけど、『ピロリン♪』は着信無音設定メール着信時に困っています。

もしかしたらHDMobiMailの問題ではないのかも知れませんが、よろしくお願いします。
Posted by てるてる at 2007年10月15日 11:32
>てるてるさん
黄緑? 黄緑はHDMobiMailでは点けてないです。
esまでの青が仕様変更になったのならアレですが。
出ている音はバルーンが出てくるときの音だと思います。
こちらでは制御はしてませんが、
os側で鳴らしているみたいです。
BG送受信時に通知出た方が
分かりやすいかなと思ったので。
(音だけで出てこないけど・・・orz)
私は長押しでChkMail動かしているので
通知無いと単押し(長押し時間不足)
で別の動きをしてしまうためです。

外す対応はできますが
その場合、BG送受信で
バルーン通知出てこなくなります。

・・・いや待てよ?

「サイレント」チェック時はバルーンも出さないってのはどうでしょう?
これなら簡単に対応できます。
Posted by ひで@き at 2007年10月15日 12:29
早速ご返事ありがとうございます。

黄緑はもう少し調べてみます。
恐らくHDMobiMailのバージョンアップ時に、ver.0.821のまんまでver.0.9.13のHDMobiMail.exeだけを差し替えたりしたせいで内部のカウントがおかしくなってるのかも知れません。

音に対しては、おっしゃってる「サイレント」でOKだったりするのですが、起動時に毎回サイレントをチェックしないといけないのがちょっと残念かも知れません…。

あっいずれにしてもすばらしいソフトを利用させて頂いているだけでもありがたいですので、決してご無理なさらないでくださいね。

これからも応援しています。
Posted by てるてる at 2007年10月15日 18:47
その後いろいろ調べたところ、「設定」の「個人用タブ」−「音と通知」の「□プログラム」の下の「□通知(アラーム、予定など)」をオフにすると、黄緑点滅も音も出ないことを確認しました。

アラームも使ってないので、とりあえずこれで行こうかと思います。
Posted by てるてる at 2007年10月16日 09:50
>てるてるさん
あぁぁすいません。間に合わなかった。
黄緑LEDの件ですが、音と後iwatobiさんが言われているバイブレータも
全部バルーンの処理で出ているものでした。
初代だと音だけでTreoだとLEDの辺りは気にしてなかったりで
[es](から?)露骨にいろんな表現してくれていたみたいです(-_-;)

Ver0915で「サイレント」に関係なく
HDMobiMailで表示する全てのバルーンで
ただ「静かに」出すだけにしました。

すいませんでした。
Posted by ひで@き at 2007年10月16日 11:53
ありがとうございました。
続きは新たな方へコメントします。
Posted by てるてる at 2007年10月16日 16:11
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック

広告


この広告は60日以上更新がないブログに表示がされております。

以下のいずれかの方法で非表示にすることが可能です。

・記事の投稿、編集をおこなう
・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。


×

この広告は1年以上新しい記事の投稿がないブログに表示されております。