2007年10月23日

HDMobiMail for WM Ver.0.916

あいこん.jpg

2007.10.23 ver.0.916

詳細については以下をご覧下さい。
MI-GI-WAなソフトサポートページ

1週間のご無沙汰でした。
相変わらずのバグ修正のみです。

一つだけ。
「索引ファイルがおかしい状態で作成される」
ですが
サムさんより報告があってから色々試したのですが
うまく再現できませんでした。
但し、受信時のTOP取得後の処理でどうも受信の「切れ目」で
おかしくなって索引のTOや件名等に変な文字が混入してしまったのではと思い
索引ファイルの作成処理をプレビューでのメール解析処理と同じようにしました。
(TOPの場合はちょっと違っていた)

posted by ひで@き at 01:00| 東京 ☀| Comment(22) | TrackBack(2) | HDMobiMail | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
素晴らしいソフトの提供に感謝と
バージョンアップお疲れさまです(^^;

一点だけご報告を。
メールボックス作成時にNULLな名前のメールボックスが作成でき、
この状態で振り分け等を行うとエラーとなります。
更に上記の状態でNULL名のメールボックスを削除すると、
すべてのメールが消えていました。

こんな事をする人はいないと思いますが
以上、ご報告まで。
(既出でしたらすみません・・・
Posted by Hornet at 2007年10月23日 10:49
お疲れ様です

魂の叫び・・・
初代03の液晶にクモの巣模様が入り(笑)急遽アドエスに機種変・・・あぁ!自動受信が上手く逝かん・・・ttmailいるんかな〜時間がない〜

頑張ってくださいね〜
Posted by とら at 2007年10月23日 20:15
>Hornetさん
必須チェック丸抜けしてますね・・・orz
次回入れておきます。

>とらさん
あぁぁぁぁぁなんということを(T△T)
「ふみっ」てしてしまいましたか?

 >頑張ってくださいね〜
 いや、それはこちらの台詞です。→再セットアップ

スマフォは全体的に液晶が大きいですが、
特に初代はでかいですからねぇ
Posted by ひで@き at 2007年10月23日 23:36
素晴らしい使い勝手で、使い始めてすぐとりこになってしまいました。
このようなソフトを提供していただける事に感謝します。

一点既出のバグ?のご報告させていただきます。
メールを250通程一気に受信しようとすると、50〜100通位受信した所で、何のエラーも出さずにソフト自体が落ちてしまいます。
もう一度起動すると受信したメールは受信フォルダにありません。

次に、スタートアップの常駐ソフトをAutoconnect以外外して再起動して再度受信した所全て受信できました。
私がスタートアップに登録していた常駐ソフトは、
BattStatusIndicator
filedlgchgs
lock2suspend
SortInchKey
WithATOK
WkTask
zm_helper
です。何かの参考になれば幸いです。
Posted by at 2007年10月25日 14:01
ひで@きさん、はじめまして。
最近、adesを購入しHDMobiMailを使用させていただき感謝しております。

ひとつ質問です。
コマンドラインなのですが、readmeにも一覧がないのですが、
どこかに記載されていますでしょうか?

非常に便利に使用させていただいておりますが、
コマンドラインが判れば一層便利になると思いまして…

よろしくお願いいたします。
Posted by 679 at 2007年10月25日 22:50
>「」さん
うーーーん・・・
色々いじっているんですがどうもはっきりとした原因が未だ分からずです。
受信フォルダには入ってないですがファイル自体は残っています。
(今はゴミ扱いですが)
ただ・・・2回目全部行きましたか・・・
メモリ使用量とかが分かれば良いのですが、
メール保存場所がどこにせよ、受信処理中に
メモリは減っていきます(リークもあるかも)
なので空き(ワーク、データ)メモリが足りなくなったら落ちます。
解放漏れがあるのか、OS側がなんらかのキャッシュを持っているのかはっきりしないんですよね・・(-_-;)
常駐アプリはfiledlgchgs以外使ったこと有りませんが、
そんなに容量食いそうな物なさそうですしね・・・
なんだろうか・・・ほんとに。

>679さん
あー、確かに書いてないですね・・
ただあまりご期待に添えないかと。

・HDMobiMail.exe
-R
-N
共に巡回受信

.HDMobiMailLoader.exe
mailto: メールアドレス 
→メアド指定メール作成画面表示

attach: 添付ファイル名
→添付ファイル選択済み状態でメール作成(アドレス選択画面)表示

-S
→新着通知停止

-R
→巡回受信

引数無し
→ただHDMobiMailを起動

「HDMobiMailLoader.exe」の引数は
「-S」を除くとHDMobiMail.exeの起動状態は関係有りません。

C#版からの経緯も有ってHDMobiMail.exeには
あまり引数対応は入れていません。
Loader経由でやりとりというスタンスにしてます。

要するにHDChkMai.exeはLoader [-R]をしているのと同じです。
なんで[-N]と[-R]が有るのかというと
単に当時(C#版)混乱していた結果です(-_-;)
Posted by ひで@き at 2007年10月26日 04:28
こんにちは。お疲れ様です。
今回は不具合かもっていうご報告です。

ご存じの通りアドエスでttmail→HDChkMail使いですが、
メール受信時に以下の動作をしていることに気付きました。

ttmail連動でメール受信時(つまり新着はあるって状態です)

【HDMobiMailがオフ】
未読メールが0の時/未読メールがある時
HDMobiMailが起動して新着青ランプ点灯
(これは問題ありません)

【HDMobiMailが起動しているもしくは最小化】
未読メールが0の時
HDMobiMailが起動して新着青ランプ点灯
(これも問題ありません)

未読メールがある時
HDMobiMailが起動して新着青ランプ消灯
(※これが問題の状況です)

もしかしたらこちらのローカルな問題かも知れませんが、何度テストしても再現してます。

仕様ならそれも仕方ありませんが、感覚的には未読メールがあるときにはずっとついてて欲しいなぁと思うわけです…。
Posted by てるてる at 2007年10月26日 16:01
↑最後の一行が抜けました。

一度確認の程よろしくお願い致します。
<(_ _)>
Posted by てるてる at 2007年10月26日 16:03
>てるてるさん
私がwillcomメールは使えないのであれですが・・
初代では再現しませんね。
(初代は擬似的に自動受信ができるので)

HDMobiMailでは未読があると点けて、
「未読が無いときのみ」消す処理が動きます。
(電話の不在着信が有ると消えません)

HDMobiMailの未読数の書き込み先が「共通」になっていないと
ZERO3側(他アプリ含む)が判断する未読数は
「0」ということになりアプリによってはLEDが消えるかもしれません。

憶測ですけどね・・・
Posted by ひで@き at 2007年10月27日 11:30
早速のご返事ありがとうございます。

確かにそういわれると、ttmailにコントロールがある時点でLEDが消灯しているような気もします。

HDMobiMailのVerUPの後で起こっているので、
濡れ衣だったかもしれません。

本当にゴメンナサイです。
もう少し調査続けてみます。
Posted by てるてる at 2007年10月27日 19:58
>てるてるさん
お気になさらず^^
最初見たときに「ほぇ?」と思って
ソース見るまでは自信なかったので。
といってもHDMobiMailじゃないとは
言い切れない気がしますので。

私の方で試せない為にお手数お掛けして申し訳ないです。
Posted by ひで@き at 2007年10月27日 20:26
申し訳ないなどと…本当にゴメンナサイ。

未だ途中ですがHDMobiMailの問題ではないことが確認できました。

ttmail→tmail→HDMobiMailと起動しているのを、一時的にttmail→HDMobiMailとしたら、LEDが点灯し続けていることを確認しました。

ですので完全な濡れ衣でした。
本当に申し訳ありませんでした。
<(_ _)>
Posted by てるてる at 2007年10月28日 00:20
>てるてるさん
あー、いやほんとに気にせずに。
一つ疑問が・・・
tmailって、HDMobiMailのtmailですか?

というのはおいておいて。
うーーん。やはりシステム乗っ取り系(に近い)のは
ある種メーカー仕様との戦いですねぇ。
LEDはTreoでもhTcZでもうまくいかんかったんですよ・・orz
(ZERO3と同じじゃなくてAPI使用で)
私はTreoで点灯させたいのです。えぇほんとに・・・
(なのでPhoneAlermで点灯させてますが)

なんにせよ直って良かったです^^
Posted by ひで@き at 2007年10月28日 01:57
ひで@きさん、こんばんわ。

引数の件、了解しました。
今後ともよろしくお願いします。
Posted by 679 at 2007年10月28日 02:01
0.916はかなり安定してきましたね。今までのご苦労の賜だと思います。まだ、時々突然落ちてしまったり、反対にまったく起動しなくなってしまったり…という現象がありますが、どういう条件で起こるのかがわかればお知らせしたいところですが残念ながら掴み切れていません。
とりあえず、再起動したり、リセットしたりすると使えるので致命的には困っていませんが、やはり気持ちは悪いですね。より完成度を上げてもらうのにお役に立てればと思っていますので、何かわかったらまた書かせていただきます。

 ところで、致命的ではないのですが、ちょっとした不具合を直していただければと思っています。
 メールの返信や転送で引用したときに、引用された文章の空行がなくなってしまっています。これは仕様でしょうか? 確か途中のRevisionまではちゃんと引用されていたように思うのですが…。

 すみませんが、時間のあるときにご検討ください。
Posted by くゎぢ at 2007年10月28日 16:37
ご苦労されているんですね…。

何せここに来てどんどんWM機が増えてますし、
それぞれで設計思想も違うでしょうし。

なおtmailはttmailと同じ、
「AsTimeGoesBy」のYUUKIさんのところのんです。
ここのtmailで鳴り分けをしています。

今回ttmailとtmailを最新にVerUPし、
完全にいちから二つのソフトの設定をし直したら、
LED問題も解決しました。
一体どこでおかしくなったんだろう…。

本当に自由に触れる分、
仕様との闘いってところがあるんでしょうねぇ。

なおくゎぢさんもおっしゃっている不安定さは、
僕のところでは
「作業メモリが一杯ですよん」
っていうメッセージが、
時折(厳密には長時間放置したとき)出ています。

本当にこれほどすばらしいソフトを利用させて頂いておきながら、
何のお力にもなれず申し訳ないです。

これからも頑張って下さい(うぅ…言葉だけなのが心苦しい…)。
Posted by てるてる at 2007年10月28日 18:15
ドタバタ(TreoWM6祭り含む)週末で何も出来ず・・・orz

http://www.pelu.jp/download/hdmobimail/hdmobimail0916a_exe.zip

>くゎぢさん
引用確認しました。
上記リンクでご確認下さい。

相変わらず変なところで落ちたり、
「なんで?」な感じで文字化けしたり・・・
もっとこー、分かりやすく落ちれば解決も楽なんですけどね(-_-;)

>てるてるさん
ありがとうございます^^
「ちょっと気になった点」のご報告だけでも大変有り難いです。
自分で使用している範囲内では
「ま、いっか」で流すところも有ったりするので。

LED関係は基本的に標準のバイブレータと違い
それぞれの端末メーカの考えが出る所ですね。
TreoだとLEDは1個、ZERO3、hTcZは2個だけど意味が違う
(BTだったり無線LANだったり電波状態だったり)
なのである程度は仕方がないかと思ってます。
結論から言えばZERO3の青LEDの方が毛色が違うと思っていますが。



C#版の頃は何もかもが手探りでしたので
いろんな要素を盛り込みすぎて収集がつかなくなったとの反省の上に
MFC版が有ります。
今回は「出来ること」と「必要なこと」を自分なりに切り分け、
なるべくシンプルなメーラーにしようとしています。
(の割にはファイルサイズがでかいが)
その上で安定性を高めようと・・・してるんですがねぇ・・・
C#版に比べたら(自分では)段違いだとは思っていますが
まぁ・・・その・・・^^;
Posted by ひで@き at 2007年10月29日 08:47
いつもすばやい対応、ありがとうございます。

正しく引用されるようになっているのを確認しました。

また何か気付いたらご報告させていただきます。

Posted by くゎぢ at 2007年10月30日 01:47
日々の開発、御苦労様です。

一つ、W-ZERO3環境でバグの可能性のある点をご報告します。

willcomメールで受信したメールをサーバから削除しない設定にしている時に、受信したwillcomメールを削除し、再度メール受信を行うと、エラーメッセージのポップアップ「POP3エラー」が2回続けて表示され、そのメールが受信されない現象が発生しました。

その後、別のメールソフトでサーバからのメールを削除するようにすれば、正常に利用できるようになります。
また、その後に新着分のメールを受信する事は可能みたいです。
また、当方でwillcom以外のメールサーバでは確認しておりません。

情報が少なくて恐縮ですが、確認してもらえたら幸いです。
Posted by kai_koen at 2007年10月31日 02:10
>kai_koenさん
可能性というかバグみたいですね・・・orz

ただPOP3エラーと有りますがその他のメッセージって出てないでしょうか?
もし出ていないようでしたらお手数ですが
「オプション→その他→デバッグモード」
で「詳細を出力」にして再度再現させ、
インストールフォルダの配下の[HDMobiLog.txt]を
migiwa-hideaki@pelu.jp
まで送って頂けないでしょうか?

テスト環境ではサーバ削除しないメールが有っても受信は出来ています。

また、HDMobiMail上からサーバ削除しないメールを削除しても再度受信はしません。
(受信済み扱いのため)

エラーとしてはそのメールのスキップの前で落ちていると思われます。


うーーーん。Willcom辞めたのが響くなぁ・・orz
Posted by ひで@き at 2007年10月31日 02:30
お疲れ様です。
時間がなくてようやくttmailで自動受診が可能になりました。が、TodayCompactが反応なし・・・なぜに・・・tmailの関係なのかな・・・差し替えてたtmail戻したらpoutlook起動した・・・アドエスちょこちょこと変わってる・・・
Posted by とら at 2007年10月31日 22:45
>とらさん
未読数レジスト先を「共通」にしてますか?
後、todaycompactのOutlook(?)は
tmail.exeを起動していたと記憶しています。
そこは差し替えないといけないかもですね・・・

HDMobiMail用のTodayプラグインでも作ればいいのでしょうが、
「1行分取る」のがどうもねぇ
Treoは狭いので(240×240)・・・orz
Posted by ひで@き at 2007年11月01日 03:55
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック

HDMobiMail for WindowsMobileの設定方法
Excerpt: 今回はひで@きさんが作ってくださっているHDMobiMail for WMの設定方法等を紹介したいと思います^^ もしかしたら設定が抜けてるところがあるかもしれないので、気づいた方はコメント....
Weblog: ケータイUserΝ
Tracked: 2007-10-24 00:56

宮城県 - 確実☆即決せフレ案内所
Excerpt: 登録からお相手検索、待ち合わせまで全てをこのサイトでチェック!
Weblog: 宮城県 - 確実☆即決せフレ案内所
Tracked: 2014-03-07 19:19

広告


この広告は60日以上更新がないブログに表示がされております。

以下のいずれかの方法で非表示にすることが可能です。

・記事の投稿、編集をおこなう
・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。


×

この広告は1年以上新しい記事の投稿がないブログに表示されております。